How to Make Selections

While in the Editor in Photoshop Elements, you can select the entire image or isolated parts of an image for editing. To select the entire image, use the commands on the Selection menu. For more precise selections, you can choose from several selection tools in the Tools palette (Figure 1).

When you make a selection, a border identifies which parts of the image are selected. After making a selection, you can add to it, subtract from it, expand it, contract it, or move it to refine the selection. You can also hide the selection border to better see the effects of your edits.

Selection Tools

- **Rectangular Marquee**: Draws square or rectangular selection borders.
- **Elliptical Marquee**: Draws round or elliptical selection borders.
- **Lasso**: Draws freehand selection borders. This tool is great for making very precise selections.
- **Magnetic Lasso**: Draws a selection border that automatically snaps to edges you drag over in a photo.
- **Polygon Lasso**: Draws multiple straight-edged segments of a selection border. Use this tool to surround an area with perfectly straight lines.
- **Magic Wand**: Selects pixels of similar color with one click.
- **Magic Selection Brush**: Automatically makes a selection based on color and texture when you draw or click an area.
- **Selection Brush**: Selects the area on which you paint.

Making Quick Selections

Sometimes all you need to do is select the entire photo or all the contents of a single layer. You do this by using the Select All command on the Select menu or by pressing Ctrl+A. When you choose Select All, the entire canvas area is selected, and changes apply to the entire canvas area for whichever layer is currently selected. Use the Select All command to copy the entire contents of one layer to another or to another file, or for applying special effects, such as filters.

You can also use the Select menu to deselect, reselect, or hide a selection.

For the following step-by-step instructions, open the Editor and click the Full Edit tab.
To make quick selections:

1. While in the Editor, click to activate the layer you want to select.

2. Choose Select > All.
   The selection border, sometimes referred to as marching ants, shows you have selected the entire canvas for the active layer. You can now cut, copy, or apply edits to the selected area (Figure 2).

3. To remove the selection, choose Select > Deselect.

4. To repeat the most recent selection, choose Select > Reselect.
   The selection border reappears.

Note: Sometimes the selection border can make it difficult to see what you are editing. You can turn off the selection border while maintaining the selection by pressing Ctrl+H. Press Ctrl+H a second time to show the selection.

Be careful when hiding a selection. Accidentally deleting parts of an image or applying an effect unintentionally is very easy when the selection border is hidden. It is best to briefly hide the selection to see what you need to see, and then turn it back on right away.
Using the Marquee Tools

Of all the selection tools, the Marquee tools are the easiest to use. If you want to select a block of the image or an oval-shaped area, use the Marquee tools (Figure 3).

Figure 3 Marquee tools

To select rectangular and elliptical areas:

1. While in the Editor, click to activate the layer you want to select.
2. In the Tools palette, select either the Rectangular or Elliptical Marquee tool. Or, press M and select your tool on the Options bar.
3. Select a mode for the tool on the Options bar (Figure 4).
   - Normal: Drag to control the size of the selection.
   - Fixed Aspect Ratio: Control the proportions of the selection by using the Width and Height boxes.
   - Fixed Size: Enter a specific size for the selection area in the Width and Height boxes.
   
   Note: You can also feather the selection, which softens the edges of the selected area.
4. Drag in the image to draw your selection (Figure 5).
   
   Note: With the Marquee tool still selected, you can drag the selected area to a new position on the image. This moves the selection border but not the selected piece of the image. To move the selected piece of the image, change to the Move tool before dragging the selection.
Modifying Selections

Making selections in Photoshop Elements can be a trial-and-error process for even the most experienced photo editors. Fortunately, Elements provides several options for adjusting your selections. You may have noticed the small square buttons on the Options bar when a selection tool is active (Figure 6). These buttons control how a selection tool functions, whether to start a new selection with each click or to add or subtract from the current selection area. They are available for all of the selection tools except the Selection Brush and Magic Selection Brush, which have their own set of options.

**Figure 6 Selection options**

- **New Selection:** Replaces the current selection with a new selection when you click and drag. With this option selected, dragging within the selection adjusts the position of the selection over the image.
- **Add to Selection:** Adds to the existing selection wherever you drag.
- **Subtract from Selection:** Removes from the existing selection wherever you drag.
- **Intersect with Selection:** This lets you drag to draw a selection and then drag again to create an overlapping selection. The area where the two selections overlap is the final selection.

You can also modify the current selection by using the Modify commands on the Select menu. For example, you can expand or contract a selection by a fixed number of pixels. Another popular technique is to select the inverse of the current selection. For example, you might select an area you want to preserve and then select the inverse (everything else) and delete it.

After making complex selections, you may also want to save them. After saving a selection, you can easily reload it from the Select menu.
To add or subtract from a selection:

1. In the Editor, choose a selection tool and select an area of the image (Figure 7).

2. To add to the selection, click the Add To Selection button on the Options bar and drag an area to add it to the selection.

   The selection border expands to include the area you added (Figure 8).

   **Note:** If you drag across the current selection border, the old and new selections blend together to form a larger selection. You can also drag to add a new selection border that is separate from the original selection (Figure 9).

3. To subtract from the selection, click the Subtract From Selection button on the Options bar and drag an area to remove it from the selection.

   **Figure 7 First selection**

   **Figure 8 Add to grow the selection**

   **Figure 9 Add an additional selection**
To create a selection from an intersection:

1. In the Editor, choose a selection tool and select an area of the image (Figure 10).

2. Select the Intersect With Selection button on the Options bar and drag an overlapping area to create the intersection (Figure 11).

   When you release the mouse button, the intersection defines the final selection (Figure 12).

---

**Figure 10** First selection

**Figure 11** Drag to create the intersection

**Figure 12** Final selection
To expand and contract selections:

1. In the Editor, choose a selection tool and select an area of the image.
2. Choose Select > Modify > Expand or Contract.
   The Expand (or Contract) Selection dialog box appears (Figure 13).
3. Enter a number of pixels between 1 and 100.
4. Click OK.
   The selection border expands or contracts by the number of pixels you specified.

To save a selection:

1. In the Editor, use one or more selection tools to define the selection border.
2. Choose Select > Save Selection.
   The Save Selection dialog box appears (Figure 14).
3. Enter a name for the selection and click OK.

To load a saved selection:

1. Choose Select > Load Selection.
   The Load Selection dialog box appears.
2. Select a selection to load from the Selection drop-down menu (Figure 15).
3. Click OK.
   The selection border appears.

Figure 13 Expand Selection dialog box

Figure 14 Save Selection dialog box

Figure 15 Load Selection dialog box
Using the Magic Selection and Selection Brushes

The Magic Selection Brush tool makes a selection based on color and texture when you draw, scribble, or click the area you want to select. The marks you make don’t need to be precise because Photoshop Elements draws the selection border for you automatically.

The basic Selection Brush tool selects whatever you paint. Use the Selection Brush to clean up a selection if the Magic Selection Brush doesn’t produce the exact results you’re looking for.

When using the brushes to identify a selection area, you can create a new selection, add to the existing selection, or subtract from the existing selection by using the buttons on the Options bar (Figure 16).

![Figure 16 Magic Selection Brush and Selection Brush options](image)

- **New Selection**: Lets you draw a new selection.
- **Indicate Foreground**: Lets you add to an existing selection.
- **Indicate Background**: Lets you subtract from an existing selection. This option is only available after you make a selection.
To select an area by using the Magic Selection Brush tool:

1. While in the Editor, click to activate the layer you want to select.

2. In the Tools palette, select the Magic Selection Brush tool. Or, press F and select the Magic Selection Brush on the Options bar.

   You can change the color and size of brush on the Options bar (Figure 17). This changes the color and size of the brush you use to mark your selection area. It does not affect the color or size of the finished selection border.

3. Drag to paint some marks on the part of the image you want to select (Figure 18).

   Note: When you paint, try to mark the range of colors and brightness you want selected.

   When you release the mouse button, Elements calculates the selection and draws the selection border automatically (Figure 19).

   If the selection isn’t perfect, you can try again or use the Indicate Foreground and Indicate Background options to add to or subtract from the selection.

4. Click the Indicate Foreground or Background button on the Options bar, and then drag to indicate the general areas you want added or removed (Figure 20).

   When you release the mouse button, Elements calculates the selection and draws the new selection border (Figure 21).
To refine a selection by using the Selection Brush tool:

1. Change to the Selection Brush tool.
2. Select the options for the tool. For example, if you want to add to the selection, click the Indicate Foreground button on the Options bar.
3. From the Options bar, select a size for the brush.
4. Drag to paint the areas you want to add to or subtract from the selection.

   Note: When refining a selection, it can be very helpful to zoom in. Use the Zoom tool, choose Zoom In on the View menu, or press Ctrl++. 

Using the Magic Wand

You can use the Magic Wand to select any part of an image with a similar color range. For example, if the image contains a large area of similar color, such as a blue sky, the Magic Wand can make selecting this large area very simple.

When using the Magic Wand, you can modify its behavior by using the settings on the Options bar (Figure 22).

**Figure 22 Magic Wand options**

- **Tolerance:** A low tolerance selects colors very similar to the pixel on which you click. A higher number selects a wider range of colors. Set a number between 0 and 255.
- **Anti-alias:** Selecting Anti-Alias produces a smooth selection edge.
- **Contiguous:** When this option is selected, only pixels that are adjacent to each other are selected. Turning it off selects pixels with a similar color throughout the image.
- **Sample All Layers:** When this option is selected, the selection is based on colors in every layer. Turning it off results in a selection based on colors in the active layer only.

Once you begin your selection, you can add to the selection by holding down the Shift key as you click. You can remove from the selection by holding down the Alt key as you click.
To make selections based on color:

1. Change to the Editor and select the Full Edit tab.
2. In the Tools palette, select the Magic Wand tool or press W.
3. Select options for the Magic Wand tool on the Options bar.
4. Click in the image to define the color for the selection (Figure 23).
5. If necessary, add to or subtract from the selection by holding down the Shift or Alt keys as you click.

In this example, the first click selected most of the sky but left the darker blue areas unselected. Raising the tolerance might also select part of the sea. To add to the selection, the Shift key was pressed while clicking the upper portion of the sky (Figure 24).

Figure 23 Define the color for the selection

Figure 24 Add to the selection with a Shift+click
Using the Lasso Tools

To make very precise selections that contain a range of colors, use the Lasso tools (Figure 25). The basic Lasso tool lets you draw a freehand line around an area to define the selection border. The area can be any shape or size. When the two ends of the line meet, the selection is complete.

If drawing the selection border freehand is too challenging, you might want to try using the Polygon Lasso. The Polygon Lasso draws perfect straight-line segments each time you click. You can add as many segments as needed to surround the selection area. By zooming in and placing lots of very short segments together, you can create a selection border that appears to have smooth curves.

If your image includes complex edges set against high-contrast backgrounds, try the Magnetic Lasso. The Magnetic Lasso draws a selection border that automatically snaps to the edges of objects you drag over in the photo. Your image needs a clearly defined edge with plenty of contrast for this to work well.

To draw selections with the Lasso tool:

1. Change to the Editor and select the Full Edit tab.
2. In the Tools palette, select the Lasso tool. Or, press L and select the Lasso tool on the Options bar.
3. On the Options bar, select options for the Lasso.
4. Drag to enclose the area you want selected (Figure 26).

   **Note:** As you drag, you are defining the selection area. When the end of your selection gets back around to where you started, the selection is complete. When using the Lasso tools, it helps to go slowly and be patient. If you are not getting the result you want, sometimes it is easier to deselect and start over.

Figure 25 Lasso tools

Figure 26 Drawing a selection with the Lasso
To make a selection by using the Polygon Lasso:

1. On the Options bar, change to the Polygon Lasso and set the Options for the tool.

2. Click where you want the first straight segment to begin, and then click again to mark where the first segment will end and the next one will begin.

3. Continue to create segments to create the selection border
   
   Note: If you zoom in and place lots of very short line segments together, you can create what appears to be a smoothly curved selection border (Figure 27).

If you make a mistake, press the Delete key to erase segments and back up. You can switch from straight-line segments to drawing freehand by pressing Alt.

4. To close the selection, position the pointer on the starting point and click.

   Note: If you zoomed in, you can zoom back out to see the finished selection.

Figure 27 Selecting with the Polygon Lasso